My goal is to configure my homepage to a new blogging framework written in Ruby. In the last weeks I’ve been working with Ruby anyway, and I liked this programming language a lot.

Since I would still call me a Ruby newcomer to the eco-structure at the moment, the small one fails already. First of all it makes sense to deal with gems and bundler. The term gems means the normal package management for Ruby. bundler is an extension which makes it possible to install the right versions for single gems.

I tried to install bundler on my Macbook as follows.

$ sudo gem install bundler                               
Successfully installed bundler-2.0.1
Parsing documentation for bundler-2.0.1
Done installing documentation for bundler after 2 seconds
1 gem installed

Subsequently, the repository for the new blog was cloned

When I run endtoend configuration install from bundler while installing the blog theme:

$ bundle install                                                                                                                                                         Traceback (most recent call last):
    1: from /Users/ivolooser/gems/bin/bundle:23:in `<main>'
/Users/ivolooser/gems/bin/bundle:23:in `load': cannot load such file -- /usr/local/lib/ruby/gems/2.6.0/gems/bundler-1.17.2/exe/bundle (LoadError)

Do I get the error message LoadError.

Apparently bundler has recently been updated to a new version. On the website of bundler you can get more information about it.

Important Note

Bundler 2 introduced a new feature that will automatically switch between Bundler v1 and v2 based on the lockfile. This feature is enabled by RubyGems (only on versions 2.7.0+) which unfortunately has a bug when you run Bundler without the appropriate version installed. You may encounter an error message like:

Can't find gem bundler (>= 0.a) with executable bundle (Gem::GemNotFoundException)

If you do, it can be fixed by installing the version of Bundler that is declared in the lockfile.

$ cat Gemfile.lock | grep -A 1 "BUNDLED WITH"

$ gem install bundler -v '1.17.3'

This bug was fixed in RubyGems 3.0.0 but backports are now being prepared for previous major versions of RubyGems. We’ll let you know when they become available.

In order to load the gems for the Endtoend repository, the bundler of version 1.17.3, i.e. version <2 is required.

$ gem install bundler -v '1.17.3'                                                                                                                                        Successfully installed bundler-1.17.3
Parsing documentation for bundler-1.17.3
Done installing documentation for bundler after 3 seconds
1 gem installed

The installation of Bundler 1.17.3 then allows the direct execution of bundle install

$ bundle install                                                                                                                                                         Fetching gem metadata from
Fetching rake 10.5.0
Installing rake 10.5.0
Using public_suffix 3.0.3
Fetching addressable 2.5.2
Installing addressable 2.5.2
Using rb-fsevent 0.10.3
Fetching ffi 1.9.25
Installing ffi 1.9.25 with native extensions
Fetching rb-inotify 0.9.10
Installing rb-inotify 0.9.10
Using sass-listen 4.0.0
Fetching sass 3.6.0
Installing sass 3.6.0
Fetching thor 0.19.4
Installing thor 0.19.4
Fetching bourbon 4.3.4
Installing bourbon 4.3.4
Using bundler 1.17.3
Using colorator 1.1.0
Using forwardable-extended 2.6.0
Using jekyll-sass-converter 1.5.2
Using ruby_dep 1.5.0
Using listen 3.1.5
Fetching jekyll-watch 1.5.1
Installing jekyll-watch 1.5.1
Using kramdown 1.17.0
Fetching liquid 4.0.0
Installing liquid 4.0.0
Using mercenary 0.3.6
Fetching pathutil 0.16.1
Installing pathutil 0.16.1
Fetching rouge 2.2.1
Installing rouge 2.2.1
Using safe_yaml 1.0.4
Fetching jekyll 3.6.3
Installing jekyll 3.6.3
Fetching jekyll-compose 0.5.0
Installing jekyll-compose 0.5.0
Fetching jekyll-feed 0.9.2
Installing jekyll-feed 0.9.2
Fetching jekyll-paginate-v2 2.0.0
Installing jekyll-paginate-v2 2.0.0
Using json 2.1.0
Fetching multi_json 1.12.1
Installing multi_json 1.12.1
Fetching pygments.rb 1.1.2
Installing pygments.rb 1.1.2
Bundle complete! 10 Gemfile dependencies, 30 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
Post-install message from sass:

Ruby Sass is deprecated and will be unmaintained as of 26 March 2019.

* If you use Sass as a command-line tool, we recommend using Dart Sass, the new
  primary implementation:

* If you use Sass as a plug-in for a Ruby web framework, we recommend using the
  sassc gem:

* For more details, please refer to the Sass blog:


comments powered by Disqus